CVE-2026-32635
Fixed upstream EPSS <1%CVSS 8.6
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20, a Cross-Site Scripting (XSS) vulnerability has been identified in the Angular runtime and compiler. It occurs when the application uses a security-sensitive attribute (for example href on an anchor tag) together with Angular's ability to internationalize attributes. Enabling internationalization for the sensitive attribute by adding i18n-<attribute> name bypasses Angular's built-in sanitization mechanism, which when combined with a data binding to untrusted user-generated data can allow an attacker to inject a malicious script. This vulnerability is fixed in 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20.
Products: @angular compiler, @angular core
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | @angular/compiler | 22.0.0-next.3 |
| npm | @angular/compiler | 21.2.4 |
| npm | @angular/compiler | 20.3.18 |
| npm | @angular/compiler | 19.2.20 |
| npm | @angular/compiler | no fix |
| npm | @angular/core | 22.0.0-next.3 |
| npm | @angular/core | 21.2.4 |
| npm | @angular/core | 20.3.18 |
| npm | @angular/core | 19.2.20 |
| npm | @angular/core | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | angular.js | no fix |
| Debian 13 | angular.js | no fix |
| Ubuntu 22.04 LTS | angular.js | no fix |
| Ubuntu 24.04 LTS | angular.js | no fix |
| Ubuntu 25.10 | angular.js | no fix |
| Ubuntu 26.04 LTS | angular.js | no fix |
| Ubuntu 26.10 | angular.js | no fix |
| Ubuntu Pro 16.04 LTS | angular.js | no fix |
| Ubuntu Pro 18.04 LTS | angular.js | no fix |
| Ubuntu Pro 20.04 LTS | angular.js | no fix |