Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-31908

No fix known EPSS <1%CVSS 9.1

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Published 2026-04-14 · CVE record · OSV

Products: Apache Software Foundation Apache APISIX