CVE-2026-31872
Fixed upstream EPSS <1%CVSS 8.7
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.6 and 8.6.32, the protectedFields class-level permission (CLP) can be bypassed using dot-notation in query WHERE clauses and sort parameters. An attacker can use dot-notation to query or sort by sub-fields of a protected field, enabling a binary oracle attack to enumerate protected field values. This affects both MongoDB and PostgreSQL deployments. This vulnerability is fixed in 9.6.0-alpha.6 and 8.6.32.
Products: parse-community parse-server
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | parse-server | 9.6.0-alpha.6 |
| npm | parse-server | 8.6.32 |