CVE-2026-31840
Fixed upstream EPSS <1%CVSS 9.3
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.2 and 8.6.28, an attacker can use a dot-notation field name in combination with the sort query parameter to inject SQL into the PostgreSQL database through an improper escaping of sub-field values in dot-notation queries. The vulnerability may also affect queries that use dot-notation field names with the distinct and where query parameters. This vulnerability only affects deployments using a PostgreSQL database. This vulnerability is fixed in 9.6.0-alpha.2 and 8.6.28.
Products: parse-community parse-server
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | parse-server | 9.6.0-alpha.2 |
| npm | parse-server | 8.6.28 |