CVE-2026-3114
Fixed in a distro release EPSS <1%CVSS 6.5
Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to validate decompressed archive entry sizes during file extraction which allows authenticated users with file upload permissions to cause a denial of service via crafted zip archives containing highly compressed entries (zip bombs) that exhaust server memory.. Mattermost Advisory ID: MMSA-2026-00598
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 10.11.12+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.2.4+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.3.2+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.4.1+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 11.4.1 |
| Go | github.com/mattermost/mattermost/server/v8 | 11.3.2 |
| Go | github.com/mattermost/mattermost/server/v8 | 11.2.4 |
| Go | github.com/mattermost/mattermost/server/v8 | 10.11.12 |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260217110922-b7d4a1f1f59b |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |