Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-30962

Fixed upstream EPSS <1%CVSS 7.1

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.

Published 2026-03-10 · CVE record · OSV

Products: parse-community parse-server

Fixed upstream

EcosystemPackageFixed in
npmparse-server9.5.2-alpha.6
npmparse-server8.6.19