CVE-2026-30852
Fixed in a distro release EPSS <1%CVSS 5.5
Caddy is an extensible server platform that uses TLS by default. From version 2.7.5 to before version 2.11.2, the vars_regexp matcher in vars.go:337 double-expands user-controlled input through the Caddy replacer. When vars_regexp matches against a placeholder like {http.request.header.X-Input}, the header value gets resolved once (expected), then passed through repl.ReplaceAll() again (the bug). This means an attacker can put {env.DATABASE_URL} or {file./etc/passwd} in a request header and the server will evaluate it, leaking environment variables, file contents, and system info. This issue has been patched in version 2.11.2.
Products: caddyserver caddy
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/caddyserver/caddy/v2 | 2.11.2 |
| Go | github.com/caddyserver/caddy/v2/modules/caddyhttp | 2.11.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu 25.10 | caddy | no fix |
| Ubuntu 26.10 | caddy | no fix |
| Ubuntu Pro 24.04 LTS | caddy | no fix |
| Ubuntu Pro 26.04 LTS | caddy | no fix |
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20260317T205859-150000.1.152.1 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |