CVE-2026-30851
Fixed in a distro release EPSS <1%CVSS 8.1
Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injection and privilege escalation. This issue has been patched in version 2.11.2.
Products: caddyserver caddy
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/caddyserver/caddy/v2 | 2.11.2 |
| Go | github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxy | 2.11.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu 25.10 | caddy | no fix |
| Ubuntu 26.10 | caddy | no fix |
| Ubuntu Pro 24.04 LTS | caddy | no fix |
| Ubuntu Pro 26.04 LTS | caddy | no fix |
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20260317T205859-150000.1.152.1 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |