Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-29057

Fixed in a distro release EPSS <1%CVSS 6.3

Next.js is a React framework for building full-stack web applications. Starting in version 9.5.0 and prior to versions 15.5.13 and 16.1.7, when Next.js rewrites proxy traffic to an external backend, a crafted `DELETE`/`OPTIONS` request using `Transfer-Encoding: chunked` could trigger request boundary disagreement between the proxy and backend. This could allow request smuggling through rewritten routes. An attacker could smuggle a second request to unintended backend routes (for example, internal/admin endpoints), bypassing assumptions that only the configured rewrite destination/path is reachable. This does not impact applications hosted on providers that handle rewrites at the CDN level, such as Vercel. The vulnerability originated in an upstream library vendored by Next.js. It is fixed in Next.js 15.5.13 and 16.1.7 by updating that dependency’s behavior so `content-length: 0` is added only when both `content-length` and `transfer-encoding` are absent, and `transfer-encoding` is no longer removed in that code path. If upgrading is not immediately possible, block chunked `DELETE`/`OPTIONS` requests on rewritten routes at the edge/proxy, and/or enforce authentication/authorization on backend routes.

Published 2026-03-18 · CVE record · OSV

Products: vercel next.js

Fixed upstream

EcosystemPackageFixed in
npmnext16.1.7
npmnext15.5.13

Distro releases

ReleasePackageFixed in
Chainguardcadence-webno fix
Chainguardjitsucom-jitsu-console2.11.0-r17
Chainguardkeep-ui0.51.0-r1
Chainguardkeep-ui-fips0.51.0-r1
Chainguardlangfuse-22.95.12-r14
Chainguardlangfuse-33.162.0-r0
Chainguardlangfuse-33.162.0-r1
Chainguardlangfuse-fips-22.95.12-r17
Chainguardlangfuse-fips-33.162.0-r0
Wolfijitsucom-jitsu-console2.11.0-r17
Wolfilangfuse-33.162.0-r0
Wolfilangfuse-33.162.0-r1