Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-28808

Fixed in a distro release EPSS <1%CVSS 8.3

Incorrect Authorization vulnerability in Erlang OTP (inets modules) allows unauthenticated access to CGI scripts protected by directory rules when served via script_alias. When script_alias maps a URL prefix to a directory outside DocumentRoot, mod_auth evaluates directory-based access controls against the DocumentRoot-relative path while mod_cgi executes the script at the ScriptAlias-resolved path. This path mismatch allows unauthenticated access to CGI scripts that directory rules were meant to protect. This vulnerability is associated with program files lib/inets/src/http_server/mod_alias.erl, lib/inets/src/http_server/mod_auth.erl, and lib/inets/src/http_server/mod_cgi.erl. This issue affects OTP from OTP 17.0 before OTP 26.2.5.19, OTP 27.3.4.10, and OTP 28.4.2, corresponding to inets from 5.10 before 9.1.0.6, 9.3.2.4, and 9.6.2. Whether OTP before OTP 17.0, corresponding to inets before 5.10, is affected is unknown.

Published 2026-04-07 · CVE record · OSV

Products: erlang otp, Red Hat OpenStack Platform 16.2, Red Hat OpenStack Platform 17.1, Red Hat OpenStack Platform 18.0

Distro releases

ReleasePackageFixed in
Debian 12erlangno fix
Debian 13erlang1:27.3.4.1+dfsg-1+deb13u3
Debian 14erlang1:27.3.4.10+dfsg-1
Ubuntu 22.04 LTSerlang1:24.2.1+dfsg-1ubuntu0.8
Ubuntu 24.04 LTSerlang1:25.3.2.8+dfsg-1ubuntu4.8
Ubuntu 25.10erlangno fix
Ubuntu 26.04 LTSerlang1:27.3.4.6+dfsg-1ubuntu0.2
Ubuntu Pro 14.04 LTSerlang1:16.b.3-dfsg-1ubuntu2.2+esm3
Ubuntu Pro 16.04 LTSerlang1:18.3-dfsg-1ubuntu3.1+esm4
Ubuntu Pro 18.04 LTSerlang1:20.2.2+dfsg-1ubuntu2+esm4
Ubuntu Pro 20.04 LTSerlang1:22.2.7+dfsg-1ubuntu0.5+esm3
openSUSE Leap 16.0erlang27.1.3-160000.4.1
openSUSE Tumbleweederlang28.5.0.4-1.1
openSUSE Tumbleweederlang2727.1.3-2.1