CVE-2026-28741
Fixed in a distro release EPSS <1%CVSS 6.8
Mattermost versions 10.11.x <= 10.11.12, 11.5.x <= 11.5.0, 11.4.x <= 11.4.2, 11.3.x <= 11.3.2 fail to validate CSRF tokens on an authentication endpoint which allows an attacker to update a user's authentication method via a CSRF attack by tricking a user into visiting a malicious page. Mattermost Advisory ID: MMSA-2026-00625
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 11.3.3+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.4.3+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.5.0+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260220133927-c29cf05d40f8 |
| Go | github.com/mattermost/mattermost/server/v8 | 11.5.0 |
| Go | github.com/mattermost/mattermost/server/v8 | 11.4.3 |
| Go | github.com/mattermost/mattermost/server/v8 | 11.3.3 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |