CVE-2026-28372
Fixed in a distro release EPSS <1%CVSS 7.4
telnetd in GNU inetutils through 2.7 allows privilege escalation that can be exploited by abusing systemd service credentials support added to the login(1) implementation of util-linux in release 2.40. This is related to client control over the CREDENTIALS_DIRECTORY environment variable, and requires an unprivileged local user to create a login.noauth file.
Products: gnu inetutils
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | inetutils | 2:2.4-2+deb12u3 |
| Debian 13 | inetutils | 2:2.6-3+deb13u2 |
| Debian 14 | inetutils | 2:2.7-3 |
| Ubuntu 24.04 LTS | inetutils | 2:2.5-3ubuntu4.2 |
| Ubuntu 25.10 | inetutils | 2:2.6-1ubuntu3.2 |
| Ubuntu 26.04 LTS | inetutils | 2:2.7-2ubuntu1.1 |
| Ubuntu Pro 14.04 LTS | inetutils | 2:1.9.2-1ubuntu0.1~esm4 |
| Ubuntu Pro 16.04 LTS | inetutils | 2:1.9.4-1ubuntu0.1~esm6 |
| Ubuntu Pro 18.04 LTS | inetutils | 2:1.9.4-3ubuntu0.1+esm5 |
| Ubuntu Pro 20.04 LTS | inetutils | 2:1.9.4-11ubuntu0.2+esm4 |
| Ubuntu Pro 22.04 LTS | inetutils | 2:2.2-2ubuntu0.2+esm1 |