CVE-2026-28292
Fixed in a distro release EPSS 1%CVSS 9.8
`simple-git`, an interface for running git commands in any node.js application, has an issue in versions 3.15.0 through 3.32.2 that allows an attacker to bypass two prior CVE fixes (CVE-2022-25860 and CVE-2022-25912) and achieve full remote code execution on the host machine. Version 3.23.0 contains an updated fix for the vulnerability.
Products: steveukx simple-git, Logging Subsystem for Red Hat OpenShift, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9, Red Hat JBoss Enterprise Application Platform 8, Red Hat JBoss Enterprise Application Platform Expansion Pack, Red Hat Process Automation 7
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | simple-git | 3.32.3 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | gemini-cli | 0.49.0-r3 |
| openSUSE Tumbleweed | heroic-games-launcher | 2.20.1-3.1 |