Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-27970

Fixed in a distro release EPSS <1%CVSS 7.6

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Versions prior to 21.2.0, 21.1.16, 20.3.17, and 19.2.19 have a cross-Site scripting vulnerability in the Angular internationalization (i18n) pipeline. In ICU messages (International Components for Unicode), HTML from translated content was not properly sanitized and could execute arbitrary JavaScript. Angular i18n typically involves three steps, extracting all messages from an application in the source language, sending the messages to be translated, and then merging their translations back into the final source code. Translations are frequently handled by contracts with specific partner companies, and involve sending the source messages to a separate contractor before receiving final translations for display to the end user. If the returned translations have malicious content, it could be rendered into the application and execute arbitrary JavaScript. When successfully exploited, this vulnerability allows for execution of attacker controlled JavaScript in the application origin. Depending on the nature of the application being exploited this could lead to credential exfiltration and/or page vandalism. Several preconditions apply to the attack. The attacker must compromise the translation file (xliff, xtb, etc.). Unlike most XSS vulnerabilities, this issue is not exploitable by arbitrary users. An attacker must first compromise an application's translation file before they can escalate privileges into the Angular application client. The victim application must use Angular i18n, use one or more ICU messages, render an ICU message, and not defend against XSS via a safe content security policy. Versions 21.2.0, 21.1.6, 20.3.17, and 19.2.19 patch the issue. Until the patch is applied, developers should consider reviewing and verifying translated content received from untrusted third parties before incorporating it in an Angular application, enabling strict CSP controls to block unauthorized JavaScript from executing on the page, and enabling Trusted Types to enforce proper HTML sanitization.

Published 2026-02-26 · CVE record · OSV

Products: angular, Red Hat Advanced Cluster Management for Kubernetes 2, Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9, Red Hat Fuse 7, Red Hat OpenShift AI (RHOAI)

Fixed upstream

EcosystemPackageFixed in
npm@angular/core21.2.0
npm@angular/core21.1.6
npm@angular/core20.3.17
npm@angular/core19.2.19
npm@angular/coreno fix

Distro releases

ReleasePackageFixed in
Chainguardkatib-earlystopping0.19.0-r31
Chainguardkatib-suggestion-goptuna-compatno fix
Chainguardkatib-suggestion-hyperband0.19.0-r31
Chainguardkatib-suggestion-hyperopt0.19.0-r40
Chainguardkatib-suggestion-hyperopt0.19.0-r31
Chainguardkatib-suggestion-nas-darts0.19.0-r31
Chainguardkatib-suggestion-nas-enas0.19.0-r31
Chainguardkatib-suggestion-optuna-enas0.19.0-r31
Chainguardkatib-suggestion-pbt-enas0.19.0-r31
Chainguardkatib-suggestion-skopt-enas0.19.0-r31
Chainguardkatib-tfevent-metricscollector0.19.0-r31
Debian 12angular.jsno fix
Debian 13angular.jsno fix
Ubuntu 22.04 LTSangular.jsno fix
Ubuntu 24.04 LTSangular.jsno fix
Ubuntu 25.10angular.jsno fix
Ubuntu 26.04 LTSangular.jsno fix
Ubuntu 26.10angular.jsno fix
Ubuntu Pro 16.04 LTSangular.jsno fix
Ubuntu Pro 18.04 LTSangular.jsno fix
Ubuntu Pro 20.04 LTSangular.jsno fix
Wolfikatib-earlystopping0.19.0-r31
Wolfikatib-suggestion-goptuna-compatno fix
Wolfikatib-suggestion-hyperband0.19.0-r31
Wolfikatib-suggestion-hyperopt0.19.0-r31
Wolfikatib-suggestion-hyperopt0.19.0-r40
Wolfikatib-suggestion-nas-darts0.19.0-r31
Wolfikatib-suggestion-nas-enas0.19.0-r31
Wolfikatib-suggestion-optuna-enas0.19.0-r31
Wolfikatib-suggestion-pbt-enas0.19.0-r31
Wolfikatib-suggestion-skopt-enas0.19.0-r31
Wolfikatib-tfevent-metricscollector0.19.0-r31