CVE-2026-27596
Fixed in a distro release EPSS <1%CVSS 2.7
Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. Prior to version 0.28.8, an out-of-bounds read was found in Exiv2. The vulnerability is in the preview component, which is only triggered when running Exiv2 with an extra command line argument, like -pp. The out-of-bounds read is at a 4GB offset, which usually causes Exiv2 to crash. This issue has been patched in version 0.28.8.
Products: exiv2
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Amazon Linux 2 | exiv2 | 0.27.0-4.amzn2.0.7 |
| Amazon Linux 2 | exiv2-devel | 0.27.0-4.amzn2.0.7 |
| Amazon Linux 2 | exiv2-doc | 0.27.0-4.amzn2.0.7 |
| Amazon Linux 2 | exiv2-libs | 0.27.0-4.amzn2.0.7 |
| Amazon Linux 2023 | exiv2 | 0.28.5-132.amzn2023 |
| Amazon Linux 2023 | exiv2-devel | 0.28.5-132.amzn2023 |
| Amazon Linux 2023 | exiv2-doc | 0.28.5-132.amzn2023 |
| Amazon Linux 2023 | exiv2-libs | 0.28.5-132.amzn2023 |
| Debian 12 | exiv2 | no fix |
| Debian 13 | exiv2 | no fix |
| Debian 14 | exiv2 | 0.28.8+dfsg-1 |
| SUSE Linux Enterprise Module for Desktop Applications 15 SP7 | exiv2 | 0.27.5-150400.15.7.1 |
| SUSE Linux Enterprise Server 16.0 | exiv2 | 0.28.8-160000.1.1 |
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | exiv2 | 0.23-12.26.1 |
| SUSE Linux Enterprise Server for SAP applications 16.0 | exiv2 | 0.28.8-160000.1.1 |
| Ubuntu 22.04 LTS | exiv2 | 0.27.5-3ubuntu1.1 |
| Ubuntu 24.04 LTS | exiv2 | 0.27.6-1ubuntu0.1 |
| Ubuntu 25.10 | exiv2 | 0.28.5+dfsg-1ubuntu0.1 |
| Ubuntu Pro 16.04 LTS | exiv2 | 0.25-2.1ubuntu16.04.7+esm5 |
| Ubuntu Pro 18.04 LTS | exiv2 | 0.25-3.1ubuntu0.18.04.11+esm1 |
| Ubuntu Pro 20.04 LTS | exiv2 | 0.27.2-8ubuntu2.7+esm1 |
| openSUSE Leap 16.0 | exiv2 | 0.28.8-160000.1.1 |