CVE-2026-27121
Fixed in a distro release EPSS <1%CVSS 5.1
svelte performance oriented web framework. Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. This vulnerability is fixed in 5.51.5.
Products: sveltejs svelte
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | svelte | 5.51.5 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | langfuse-2-worker | no fix |
| Chainguard | langfuse-3-worker | 3.163.0-r0 |
| Chainguard | langfuse-fips-2-worker | no fix |
| Chainguard | langfuse-fips-3-worker | 3.163.0-r0 |
| Chainguard | langfuse-fips-3.152-worker | no fix |
| Wolfi | langfuse-3-worker | 3.163.0-r0 |