CVE-2026-25783
Fixed in a distro release EPSS <1%CVSS 4.3
Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly validate User-Agent header tokens which allows an authenticated attacker to cause a request panic via a specially crafted User-Agent header. Mattermost Advisory ID: MMSA-2026-00586
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 5.3.2-0.20260129181235-1346cf529aef |
| Go | github.com/mattermost/mattermost-server | 10.11.11 |
| Go | github.com/mattermost/mattermost-server | 11.2.3 |
| Go | github.com/mattermost/mattermost-server | 11.3.1 |
| Go | github.com/mattermost/mattermost-server | 10.11.11+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.2.3+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.3.1+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260129181235-1346cf529aef |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20260326T203309-150000.1.155.2 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |