CVE-2026-24747
Fixed in a distro release EPSS <1%CVSS 8.8
PyTorch is a Python package that provides tensor computation. Prior to version 2.10.0, a vulnerability in PyTorch's `weights_only` unpickler allows an attacker to craft a malicious checkpoint file (`.pth`) that, when loaded with `torch.load(..., weights_only=True)`, can corrupt memory and potentially lead to arbitrary code execution. Version 2.10.0 fixes the issue.
Products: pytorch, Red Hat OpenShift AI 2.25, Red Hat OpenShift AI (RHOAI)
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | pytorch | 2.10.0 |
| PyPI | torch | 2.10.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | pytorch | no fix |
| Debian 13 | pytorch | no fix |
| Debian 14 | pytorch | 2.12.0+dfsg2-1 |
| Ubuntu 22.04 LTS | pytorch | no fix |
| Ubuntu 25.10 | pytorch | no fix |
| Ubuntu 26.04 LTS | pytorch | no fix |
| Ubuntu 26.10 | pytorch | no fix |