Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-24421

Fixed upstream EPSS 2%CVSS 6.5

phpMyFAQ is an open source FAQ web application. Versions 4.0.16 and below have flawed authorization logic which exposes the /api/setup/backup endpoint to any authenticated user despite their permissions. SetupController.php uses userIsAuthenticated() but does not verify that the requester has configuration/admin permissions. Non-admin users can trigger a configuration backup and retrieve its path. The endpoint only checks authentication, not authorization, and returns a link to the generated ZIP. This issue is fixed in version 4.0.17.

Published 2026-01-24 · CVE record · OSV

Products: thorsten phpmyfaq

Fixed upstream

EcosystemPackageFixed in
Packagistphpmyfaq/phpmyfaq4.0.17
Packagistthorsten/phpmyfaq4.0.17