Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-23943

Fixed in a distro release EPSS <1%CVSS 6.9

Improper Handling of Highly Compressed Data (Compression Bomb) vulnerability in Erlang OTP ssh (ssh_transport modules) allows Denial of Service via Resource Depletion. The SSH transport layer advertises legacy zlib compression by default and inflates attacker-controlled payloads pre-authentication without any size limit, enabling reliable memory exhaustion DoS. Two compression algorithms are affected: * zlib: Activates immediately after key exchange, enabling unauthenticated attacks * zlib@openssh.com: Activates post-authentication, enabling authenticated attacks Each SSH packet can decompress ~255 MB from 256 KB of wire data (1029:1 amplification ratio). Multiple packets can rapidly exhaust available memory, causing OOM kills in memory-constrained environments. This vulnerability is associated with program files lib/ssh/src/ssh_transport.erl and program routines ssh_transport:decompress/2, ssh_transport:handle_packet_part/4. This issue affects OTP from OTP 17.0 before OTP 28.4.1, OTP 27.3.4.9 and OTP 26.2.5.18, corresponding to ssh from 3.0.1 before 5.5.1, 5.2.11.6 and 5.1.4.14.

Published 2026-03-13 · CVE record · OSV

Products: erlang otp

Distro releases

ReleasePackageFixed in
Debian 12erlang1:25.2.3+dfsg-1+deb12u4
Debian 13erlang1:27.3.4.1+dfsg-1+deb13u2
Debian 14erlang1:27.3.4.9+dfsg-1
Ubuntu 22.04 LTSerlang1:24.2.1+dfsg-1ubuntu0.8
Ubuntu 24.04 LTSerlang1:25.3.2.8+dfsg-1ubuntu4.8
Ubuntu 25.10erlangno fix
Ubuntu 26.04 LTSerlang1:27.3.4.6+dfsg-1ubuntu0.2
Ubuntu Pro 14.04 LTSerlang1:16.b.3-dfsg-1ubuntu2.2+esm3
Ubuntu Pro 16.04 LTSerlang1:18.3-dfsg-1ubuntu3.1+esm4
Ubuntu Pro 18.04 LTSerlang1:20.2.2+dfsg-1ubuntu2+esm4
Ubuntu Pro 20.04 LTSerlang1:22.2.7+dfsg-1ubuntu0.5+esm3
openSUSE Leap 16.0erlang27.1.3-160000.4.1
openSUSE Tumbleweederlang2727.1.3-2.1