CVE-2026-23870
Fixed upstream EPSS 2%CVSS 7.5
A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lead to server crashes, out-of-memory exceptions or excessive CPU usage; affecting the following packages: react-server-dom-webpack, react-server-dom-parcel, react-server-dom-turbopack (versions 19.0.0 through 19.0.5, 19.1.0 through 19.1.6, and 19.2.0 through 19.2.5).
Products: Meta react-server-dom-turbopack, Meta react-server-dom-parcel, Meta react-server-dom-webpack
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | react-server-dom-parcel | 19.0.6 |
| npm | react-server-dom-parcel | 19.1.7 |
| npm | react-server-dom-parcel | 19.2.6 |
| npm | react-server-dom-turbopack | 19.0.6 |
| npm | react-server-dom-turbopack | 19.1.7 |
| npm | react-server-dom-turbopack | 19.2.6 |
| npm | react-server-dom-webpack | 19.0.6 |
| npm | react-server-dom-webpack | 19.1.7 |
| npm | react-server-dom-webpack | 19.2.6 |