CVE-2026-22733
Fixed in a distro release EPSS <1%CVSS 8.2
Spring Boot applications with Actuator can be vulnerable to an "Authentication Bypass" vulnerability when an application endpoint that requires authentication is declared under the path used by the CloudFoundry Actuator endpoints. This issue affects Spring Security: from 4.0.0 through 4.0.3, from 3.5.0 through 3.5.11, from 3.4.0 through 3.4.14, from 3.3.0 through 3.3.17, from 2.7.0 through 2.7.31.
Products: Spring Security
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.springframework.boot:spring-boot-starter-actuator | 4.0.4 |
| Maven | org.springframework.boot:spring-boot-starter-actuator | 3.5.12 |
| Maven | org.springframework.boot:spring-boot-starter-actuator | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | apache-nifi-registry | 2.8.0-r3 |
| Chainguard | camunda-8.8 | 8.8.22-r0 |
| Chainguard | camunda-zeebe-8.6 | 8.6.39-r0 |
| Chainguard | camunda-zeebe-8.7 | 8.7.27-r0 |
| Chainguard | camunda-zeebe-8.8 | 8.8.22-r0 |
| Chainguard | kayenta-2025.0 | no fix |
| Chainguard | kayenta-2025.1 | no fix |
| Chainguard | kayenta-2025.2 | no fix |
| Chainguard | kayenta-2025.4 | no fix |
| Chainguard | kayenta-2026.0 | no fix |
| Chainguard | kayenta-2026.1 | no fix |
| Chainguard | kayenta-fips-2025.0 | no fix |
| Chainguard | kayenta-fips-2025.1 | no fix |
| Chainguard | kayenta-fips-2025.2 | no fix |
| Chainguard | kayenta-fips-2025.4 | no fix |
| Chainguard | kayenta-fips-2026.0 | no fix |
| Chainguard | kayenta-fips-2026.1 | no fix |
| Chainguard | ontop | no fix |
| Chainguard | ontop-fips | no fix |
| Wolfi | apache-nifi-registry | 2.8.0-r3 |