CVE-2026-22545
Fixed in a distro release EPSS <1%CVSS 3.1
Mattermost versions 10.11.x <= 10.11.10 fail to validate user's authentication method when processing account auth type switch which allows an authenticated attacker to change account password without confirmation via falsely claiming a different auth provider.. Mattermost Advisory ID: MMSA-2026-00583
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 5.3.2-0.20260127144908-ced9a56e3988 |
| Go | github.com/mattermost/mattermost-server | 10.11.11 |
| Go | github.com/mattermost/mattermost-server | 11.2.3 |
| Go | github.com/mattermost/mattermost-server | 11.3.1 |
| Go | github.com/mattermost/mattermost-server | 10.11.11+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.2.3+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.3.1+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260127144908-ced9a56e3988 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20260326T203309-150000.1.155.2 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |