CVE-2026-19012
Fixed in a distro release EPSS <1%CVSS 5.3
Consul Community Edition and Consul Enterprise 1.18.0 through 2.0.2 are vulnerable to an authenticated denial of service in the Enterprise-to-Community Edition downgrade path that may allow an authorized caller to crash the Consul server. A caller with config-entry write permission can submit a service-router configuration entry that causes the agent to exit unexpectedly. This vulnerability, CVE-2026-19012, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.
Products: HashiCorp Consul, HashiCorp Consul Enterprise
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | consul-1.22 | no fix |
| Chainguard | consul-2.0 | no fix |
| Chainguard | consul-fips-1.22 | no fix |
| Chainguard | consul-fips-2.0 | 2.0.3-r0 |
| Debian 11 | consul | no fix |
| Ubuntu 18.04 LTS | consul | no fix |
| Ubuntu 20.04 LTS | consul | no fix |
| Ubuntu 22.04 LTS | consul | no fix |