CVE-2026-15970
Fixed in a distro release EPSS <1%CVSS 4.2
Consul Community Edition and Consul Enterprise 1.20.1 through 2.0.2 are vulnerable to an L7 intention authorization bypass when a service proxy is configured with a custom public listener. An authenticated mesh workload may reach HTTP paths that are blocked by a path-based deny intention. This vulnerability, CVE-2026-15970, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.
Products: HashiCorp Consul, HashiCorp Consul Enterprise
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | consul-1.22 | no fix |
| Chainguard | consul-2.0 | 2.0.4-r0 |
| Chainguard | consul-fips-1.22 | no fix |
| Chainguard | consul-fips-2.0 | 2.0.3-r0 |
| Debian 11 | consul | no fix |
| Ubuntu 18.04 LTS | consul | no fix |
| Ubuntu 20.04 LTS | consul | no fix |
| Ubuntu 22.04 LTS | consul | no fix |