CVE-2026-12480
Fixed upstream EPSS <1%CVSS 5.5
Keras versions up to and including 3.13.2 are vulnerable to an arbitrary HDF5 file read due to an incomplete fix for CVE-2026-1669. The vulnerability resides in the `H5IOStore._verify_dataset()` and `file_editor.py` methods, which fail to check the `dataset.is_virtual` property of HDF5 datasets. This allows an attacker to craft a malicious `.keras` model archive or `.h5` weights file containing a Virtual Dataset (VDS) that references external HDF5 files on the victim's filesystem. When the victim loads the model using `keras.models.load_model()` or `keras.saving.load_model()`, the external file is transparently read, leading to potential information disclosure. Fixed in versions 3.12.2 and 3.14.1.
Products: keras-team/keras
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | keras | 3.12.3 |
| PyPI | keras | 3.15.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | keras | no fix |
| Ubuntu 18.04 LTS | keras | no fix |
| Ubuntu 20.04 LTS | keras | no fix |