CVE-2026-115387
Fixed upstream EPSS <1%CVSS 6.2
Wasmtime before 36.0.16, 37.0.0 before 48.0.3, and 49.0.0 before 49.0.1 contains a denial of service vulnerability in wasmtime-wasi that allows guest WASI programs to panic the host via overflowing filesystem timestamps. Attackers can pass atim or mtim values whose sub-second field overflows the seconds field to path_filestat_set_times, fd_filestat_set_times, set-times, or set-times-at, crashing the host.
Products: bytecodealliance wasmtime
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| crates.io | wasmtime-wasi | 36.0.16 |
| crates.io | wasmtime-wasi | 48.0.3 |
| crates.io | wasmtime-wasi | 49.0.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 13 | rust-wasmtime | no fix |
| Debian 14 | rust-wasmtime | no fix |