CVE-2026-114109
Fixed upstream EPSS <1%CVSS 8.8
uv before 0.11.15 contains a path traversal vulnerability that allows malicious wheels to write files outside the scripts directory via crafted console_scripts or gui_scripts entry point names. Attackers who induce users to install a malicious wheel can place executables in PATH directories, shadowing or overwriting existing binaries for code execution.
Products: astral-sh uv
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | uv | 0.11.15 |
| crates.io | uv | 0.11.15 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 14 | uv | no fix |
| Ubuntu 26.10 | uv | no fix |