CVE-2026-114055
Fixed upstream EPSS <1%CVSS 7.5
vLLM from 0.7.3 before 0.31.0 contains an uncontrolled resource consumption vulnerability that allows remote clients to control multimodal processor parameters by supplying per-request mm_processor_kwargs. Attackers can set large image size, patch count, crop count, or frame count values in Isaac, InternVL, H2OVL, and other processors to exhaust memory and terminate the shared server.
Products: vllm-project vllm
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | vllm | 0.31.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | kserve-huggingfaceserver-cuda-13.3 | no fix |
| Chainguard | lmcache-cuda-12.8 | no fix |
| Chainguard | nemo-rl-cuda-13.0-vllm | no fix |
| Chainguard | py3.10-vllm-cuda-12.4 | no fix |
| Chainguard | py3.12-vllm-cuda-12.4 | no fix |
| Chainguard | vllm-omni-cuda-13.0 | no fix |