CVE-2026-114047
Fixed in a distro release EPSS <1%CVSS 6.8
FreeRDP from 2.0.0 before 3.32.0 contains an improper certificate validation vulnerability in its proxy that accepts untrusted target TLS certificates when no verification module is configured. Network-positioned attackers can intercept the proxy's outbound connection and present a self-signed, wrong-hostname certificate to impersonate the RDP target and receive proxied session data.
Products: FreeRDP
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | freerdp2 | no fix |
| Debian 13 | freerdp3 | no fix |
| Debian 14 | freerdp3 | 3.32.0+dfsg-1 |
| Ubuntu 16.04 LTS | freerdp | no fix |
| Ubuntu 18.04 LTS | freerdp | no fix |
| Ubuntu 22.04 LTS | freerdp2 | no fix |
| Ubuntu 24.04 LTS | freerdp3 | no fix |
| Ubuntu 26.04 LTS | freerdp3 | no fix |
| Ubuntu 26.10 | freerdp3 | no fix |
| Ubuntu Pro 18.04 LTS | freerdp2 | no fix |
| Ubuntu Pro 20.04 LTS | freerdp2 | no fix |
| Ubuntu Pro 24.04 LTS | freerdp2 | no fix |