CVE-2026-110871
Fixed in a distro release EPSS <1%CVSS 6.5
Nodemailer from 3.0.0 before 10.0.10 contains a denial of service vulnerability in MessageParser.parseHeaders that allows users to exhaust CPU through quadratic header unfolding. Attackers can supply large recipient lists or long headers that fold into tens of thousands of continuation lines, blocking the Node.js event loop during DKIM signing.
Products: nodemailer
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | nodemailer | 10.0.10 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | node-nodemailer | no fix |
| Debian 13 | node-nodemailer | no fix |
| Debian 14 | node-nodemailer | 10.0.10+~8.0.1-1 |
| Ubuntu 20.04 LTS | node-nodemailer | no fix |
| Ubuntu 22.04 LTS | node-nodemailer | no fix |
| Ubuntu 24.04 LTS | node-nodemailer | no fix |
| Ubuntu 26.04 LTS | node-nodemailer | no fix |
| Ubuntu 26.10 | node-nodemailer | no fix |