CVE-2026-110264
Fixed in a distro release EPSS 1%CVSS 10.0
An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.
Products: GitLab
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | ruby-3.3 | 3.3.12-r10 |
| Chainguard | ruby-3.3-dev | 3.3.12-r10 |
| Chainguard | ruby-3.3-doc | 3.3.12-r10 |
| Chainguard | ruby-3.4 | 3.4.11-r5 |
| Chainguard | ruby-3.4-dev | 3.4.11-r5 |
| Chainguard | ruby-3.4-doc | 3.4.11-r5 |
| Chainguard | ruby-4.0 | 4.0.7-r6 |
| Chainguard | ruby-4.0-dev | 4.0.7-r6 |
| Chainguard | ruby-4.0-doc | 4.0.7-r6 |
| Debian 12 | ruby3.1 | no fix |
| Debian 13 | ruby3.3 | no fix |
| Debian 14 | ruby3.3 | no fix |
| Wolfi | ruby-3.3 | 3.3.12-r10 |
| Wolfi | ruby-3.3-dev | 3.3.12-r10 |
| Wolfi | ruby-3.3-doc | 3.3.12-r10 |
| Wolfi | ruby-3.4 | 3.4.11-r5 |
| Wolfi | ruby-3.4-dev | 3.4.11-r5 |
| Wolfi | ruby-3.4-doc | 3.4.11-r5 |
| Wolfi | ruby-4.0 | 4.0.7-r6 |
| Wolfi | ruby-4.0-dev | 4.0.7-r6 |
| Wolfi | ruby-4.0-doc | 4.0.7-r6 |