CVE-2026-109964
Fixed in a distro release EPSS <1%CVSS 5.6
ImageMagick before 7.1.2-33 and 6.9.13-58 contains a heap buffer underwrite vulnerability in DecodeImage() in coders/pict.c on 32-bit builds due to pointer arithmetic overflow. Attackers can supply a crafted PICT file with maximized row, column and bytes-per-line values to bypass bounds checks and write up to 128 controlled bytes below the heap buffer, causing crashes or code execution.
Products: imagemagick
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | imagemagick | no fix |
| Debian 13 | imagemagick | no fix |
| Debian 14 | imagemagick | no fix |
| Ubuntu 26.10 | imagemagick | no fix |
| Ubuntu Pro 14.04 LTS | imagemagick | no fix |
| Ubuntu Pro 16.04 LTS | imagemagick | no fix |
| Ubuntu Pro 18.04 LTS | imagemagick | no fix |
| Ubuntu Pro 20.04 LTS | imagemagick | no fix |
| Ubuntu Pro 22.04 LTS | imagemagick | no fix |
| Ubuntu Pro 24.04 LTS | imagemagick | no fix |
| Ubuntu Pro 26.04 LTS | imagemagick | no fix |
| openSUSE Tumbleweed | GraphicsMagick | 1.3.49-1.1 |
| openSUSE Tumbleweed | ImageMagick | 7.1.2.34-1.1 |