CVE-2026-109449
Fixed in a distro release EPSS <1%CVSS 8.7
In Symfony Expression Language versions prior to 5.4.54, 6.4.48, 7.4.21, and 8.1.9, the parser of the ExpressionLanguage component built its node tree with no bound on its depth. An expression made of tens of thousands of nested unary operators, array literals, binary operators or property accesses crashed the PHP process, while the tree was being freed. #[Assert\ExpressionSyntax] passes the validated value to ExpressionLanguage::lint(), so an application validating expressions written by its users could be crashed by a single request, and so could any code parsing untrusted expressions. This issue affects symfony/expression-language through v5.4.53, v6.0.0-BETA1 through v6.4.47, v7.0.0-BETA1 through v7.4.20, and v8.0.0-BETA1 through v8.1.8.
Products: sensiolabs symfony
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | symfony | no fix |
| Debian 13 | symfony | no fix |
| Debian 14 | symfony | 7.4.21+dfsg-1 |
| Ubuntu 16.04 LTS | symfony | no fix |
| Ubuntu 26.04 LTS | symfony | no fix |
| Ubuntu 26.10 | symfony | no fix |
| Ubuntu Pro 18.04 LTS | symfony | no fix |
| Ubuntu Pro 20.04 LTS | symfony | no fix |
| Ubuntu Pro 22.04 LTS | symfony | no fix |
| Ubuntu Pro 24.04 LTS | symfony | no fix |