Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-109413

Fixed in a distro release EPSS <1%CVSS 8.7

In Symfony YAML prior to versions 5.4.54, 6.4.45, 7.4.18, and 8.1.6, Yaml\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting level that the rest of the parser bounds with maxNestingLevel. A document made of deeply nested inline collections, such as [[[[...]]]], exhausted the stack while it was being lexed: depending on the PHP version and its stack settings, the process crashed or the request ended with a fatal error. Any code parsing untrusted YAML is affected. That includes #[MapRequestPayload] when the Yaml component is installed and the endpoint does not restrict acceptFormat: a single unauthenticated request with a YAML content type is enough. This issue affects symfony/yaml through v5.4.53, v6.0.0-BETA1 through v6.4.44, v7.0.0-BETA1 through v7.4.17, and v8.0.0-BETA1 through v8.1.5.

Published 2026-10-15 · CVE record · OSV

Products: sensiolabs symfony

Distro releases

ReleasePackageFixed in
Debian 12symfonyno fix
Debian 13symfonyno fix
Debian 14symfony7.4.18+dfsg-1
Ubuntu 16.04 LTSsymfonyno fix
Ubuntu 26.04 LTSsymfonyno fix
Ubuntu 26.10symfonyno fix
Ubuntu Pro 18.04 LTSsymfonyno fix
Ubuntu Pro 20.04 LTSsymfonyno fix
Ubuntu Pro 22.04 LTSsymfonyno fix
Ubuntu Pro 24.04 LTSsymfonyno fix