CVE-2026-109253
Fixed in a distro release EPSS <1%CVSS 5.3
FreeRDP from 3.9.0 before 3.32.0 contains an out-of-bounds read vulnerability in the RDPEAR NDR scalar readers, which check value length before consuming alignment padding. Malicious or compromised RDP servers can send crafted unaligned RDPEAR payloads, such as CreateApReqAuthenticatorReq messages, to clients using Remote Credential Guard, causing over-reads and potentially crashing the client process.
Products: FreeRDP
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Amazon Linux 2023 | freerdp | 2:3.32.1-1.amzn2023.0.1 |
| Amazon Linux 2023 | freerdp-devel | 2:3.32.1-1.amzn2023.0.1 |
| Amazon Linux 2023 | freerdp-libs | 2:3.32.1-1.amzn2023.0.1 |
| Amazon Linux 2023 | freerdp-server | 2:3.32.1-1.amzn2023.0.1 |
| Amazon Linux 2023 | libwinpr | 2:3.32.1-1.amzn2023.0.1 |
| Amazon Linux 2023 | libwinpr-devel | 2:3.32.1-1.amzn2023.0.1 |
| Debian 12 | freerdp2 | no fix |
| Debian 13 | freerdp3 | no fix |
| Debian 14 | freerdp3 | 3.32.0+dfsg-1 |
| Ubuntu 16.04 LTS | freerdp | no fix |
| Ubuntu 18.04 LTS | freerdp | no fix |
| Ubuntu 22.04 LTS | freerdp2 | no fix |
| Ubuntu 24.04 LTS | freerdp3 | 3.32.0+dfsg-0ubuntu0.24.04.1 |
| Ubuntu 26.04 LTS | freerdp3 | 3.32.0+dfsg-0ubuntu0.26.04.1 |
| Ubuntu Pro 18.04 LTS | freerdp2 | no fix |
| Ubuntu Pro 20.04 LTS | freerdp2 | no fix |
| Ubuntu Pro 24.04 LTS | freerdp2 | no fix |