CVE-2026-103119
Fixed in a distro release EPSS <1%CVSS 9.1
Buffer under-read vulnerability in Apache Tomcat meant that a large non-blocking write could result in the response body being split between the current request and the next request received on that connection leading most likely to failure of the second request and possibly leakage of data from the first response to the second. This issue affects Apache Tomcat: from 11.0.0-M25 through 11.0.26. Users are recommended to upgrade to version 11.0.27, which fixes the issue.
Products: Apache Software Foundation Apache Tomcat
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 13 | tomcat11 | no fix |
| Debian 14 | tomcat11 | no fix |
| Ubuntu 24.04 LTS | tomcat10 | no fix |
| Ubuntu 24.04 LTS | tomcat9 | no fix |
| Ubuntu 26.04 LTS | tomcat10 | no fix |
| Ubuntu 26.04 LTS | tomcat11 | no fix |
| Ubuntu 26.04 LTS | tomcat9 | no fix |
| Ubuntu 26.10 | tomcat10 | no fix |
| Ubuntu 26.10 | tomcat11 | no fix |
| Ubuntu 26.10 | tomcat9 | no fix |
| Ubuntu Pro 14.04 LTS | tomcat6 | no fix |
| Ubuntu Pro 14.04 LTS | tomcat7 | no fix |
| Ubuntu Pro 16.04 LTS | tomcat7 | no fix |
| Ubuntu Pro 16.04 LTS | tomcat8 | no fix |
| Ubuntu Pro 18.04 LTS | tomcat8 | no fix |
| Ubuntu Pro 18.04 LTS | tomcat9 | no fix |
| Ubuntu Pro 20.04 LTS | tomcat9 | no fix |
| Ubuntu Pro 22.04 LTS | tomcat9 | no fix |
| openSUSE Tumbleweed | tomcat11 | 11.0.27-1.1 |