CVE-2026-102829
Fixed in a distro release EPSS <1%CVSS 9.2
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it as allowUnsafeEditor. A consuming application that forwards attacker-influenced environment values can therefore allow Git to invoke an attacker-selected editor during operations such as commit amendment or interactive rebase when no higher-priority editor setting overrides VISUAL and Git's terminal prerequisites are met. The executable runs with the privileges of the Node.js process. This issue is fixed in argv-parser 2.0.1.
Products: steveukx git-js
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | @simple-git/argv-parser | 2.0.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | gemini-cli | no fix |
| Chainguard | keycloak-26.6 | no fix |
| Chainguard | keycloak-26.6-iamguarded-compat | no fix |
| Chainguard | keycloak-26.7 | no fix |
| Chainguard | keycloak-26.7-iamguarded-compat | no fix |
| Chainguard | keycloak-26.8 | 26.8.0-r1 |
| Chainguard | keycloak-26.8-iamguarded-compat | 26.8.0-r1 |
| Chainguard | renovate | 44.164.5-r0 |
| Chainguard | renovate | 44.164.1-r0 |
| Wolfi | keycloak-26.6 | no fix |
| Wolfi | keycloak-26.6-iamguarded-compat | no fix |
| Wolfi | renovate | 44.164.5-r0 |
| Wolfi | renovate | 44.164.1-r0 |