Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-102827

Fixed in a distro release EPSS <1%CVSS 8.1

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clone-side abbreviation handling does not protect the push path. This issue is fixed in 4.0.0.

Published 2026-09-29 · CVE record · OSV

Products: steveukx git-js

Fixed upstream

EcosystemPackageFixed in
npmsimple-git4.0.0

Distro releases

ReleasePackageFixed in
Chainguardgemini-clino fix
Chainguardkeycloak-26.6no fix
Chainguardkeycloak-26.6-iamguarded-compatno fix
Chainguardkeycloak-26.7no fix
Chainguardkeycloak-26.7-iamguarded-compatno fix
Chainguardkeycloak-26.826.8.0-r1
Chainguardkeycloak-26.8-iamguarded-compat26.8.0-r1
Chainguardrenovate44.164.5-r0
Chainguardrenovate44.164.1-r0
Wolfikeycloak-26.6no fix
Wolfikeycloak-26.6-iamguarded-compatno fix
Wolfirenovate44.164.5-r0
Wolfirenovate44.164.1-r0