CVE-2026-10143
Fixed in a distro release EPSS <1%CVSS 7.5
kafka-python prior to 2.3.2 contains a denial-of-service vulnerability in SCRAM authentication handling that allows a malicious or machine-in-the-middle broker to freeze the client event loop by supplying an excessively large iteration count. In scram.py, ScramClient.process_server_first_message() passes the broker-controlled SCRAM iteration count directly to hashlib.pbkdf2_hmac() without validation, blocking producer sends, consumer polls, admin operations, and heartbeats, which can cause consumer group eviction and repeated reconnect failures.
Products: Dana Powers kafka-python, Red Hat Quay 3.10, Red Hat Quay 3.12, Red Hat Quay 3.15, Red Hat Quay 3.16, Red Hat Quay 3.9
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | kafka-python | 2.3.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | mlrun | 1.11.0-r5 |
| Chainguard | mlrun-api | 1.11.0-r5 |
| Chainguard | mlrun-api-fips | 1.11.0-r2 |
| Chainguard | mlrun-fips | 1.11.0-r2 |
| Debian 12 | python-kafka | no fix |
| Debian 13 | python-kafka | no fix |
| Debian 14 | python-kafka | 2.0.2-12 |
| Ubuntu 16.04 LTS | python-kafka | no fix |
| Ubuntu 18.04 LTS | python-kafka | no fix |
| Ubuntu 20.04 LTS | python-kafka | no fix |
| Ubuntu 22.04 LTS | python-kafka | no fix |
| Ubuntu 24.04 LTS | python-kafka | no fix |
| Ubuntu 25.10 | python-kafka | no fix |
| Ubuntu 26.04 LTS | python-kafka | no fix |
| Ubuntu 26.10 | python-kafka | no fix |