CVE-2026-10142
Fixed in a distro release EPSS <1%CVSS 7.5
kafka-python prior to 2.3.2 contains a denial-of-service vulnerability in the protocol parser that allows a malicious broker or machine-in-the-middle attacker to exhaust memory or hang connections by sending a crafted 4-byte frame length value without bounds validation. Attackers can send a specially crafted frame length through the receive_bytes() function to trigger either a multi-gigabyte memory allocation or an uncaught ValueError that leaves the connection in a broken state, causing requests to hang and consumers to stop heartbeating until restart.
Products: Dana Powers kafka-python
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | kafka-python | 2.3.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | mlrun | 1.11.0-r5 |
| Chainguard | mlrun-api | 1.11.0-r5 |
| Chainguard | mlrun-api-fips | 1.11.0-r2 |
| Chainguard | mlrun-fips | 1.11.0-r2 |
| Debian 12 | python-kafka | no fix |
| Debian 13 | python-kafka | no fix |
| Debian 14 | python-kafka | 2.0.2-13 |
| Ubuntu 16.04 LTS | python-kafka | no fix |
| Ubuntu 18.04 LTS | python-kafka | no fix |
| Ubuntu 20.04 LTS | python-kafka | no fix |
| Ubuntu 22.04 LTS | python-kafka | no fix |
| Ubuntu 24.04 LTS | python-kafka | no fix |
| Ubuntu 25.10 | python-kafka | no fix |
| Ubuntu 26.04 LTS | python-kafka | no fix |
| Ubuntu 26.10 | python-kafka | no fix |
| openSUSE Tumbleweed | python-kafka-python | 2.3.2-1.1 |