CVE-2026-100661
No fix known EPSS <1%CVSS 7.5
Netty's HTTP/3 codec (io.netty:netty-codec-http3) versions 4.2.0.Final through 4.2.17.Final contain a denial-of-service vulnerability in the QPACK prefixed-integer decoder (QpackUtil.decodePrefixedInteger), which does not bound the number of continuation bytes it will process. A remote, unauthenticated peer can open a QPACK unidirectional stream (type 0x02 encoder or 0x03 decoder) and send a first byte with all prefix bits set (e.g. 0xFF for a 7-bit prefix or 0x3F for a 5-bit prefix) followed by an endless run of 0x80 continuation bytes. The decoder returns -1 ('need more bytes'), so callers never consume the input, the ByteToMessageDecoder cumulator grows without bound, and each decode() invocation re-scans the whole accumulated buffer, yielding O(N^2) CPU cost. The result is unbounded per-connection heap growth (OutOfMemoryError) and event-loop CPU starvation, reachable in every configuration. Fixed in 4.2.18.Final.
Products: netty
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu 26.10 | netty | no fix |
| Ubuntu Pro 14.04 LTS | netty | no fix |
| Ubuntu Pro 16.04 LTS | netty | no fix |
| Ubuntu Pro 18.04 LTS | netty | no fix |
| Ubuntu Pro 20.04 LTS | netty | no fix |
| Ubuntu Pro 22.04 LTS | netty | no fix |
| Ubuntu Pro 24.04 LTS | netty | no fix |
| Ubuntu Pro 26.04 LTS | netty | no fix |