CVE-2026-0848
Fixed in a distro release EPSS <1%CVSS 10.0
NLTK versions <=3.9.2 are vulnerable to arbitrary code execution due to improper input validation in the StanfordSegmenter module. The module dynamically loads external Java .jar files without verification or sandboxing. An attacker can supply or replace the JAR file, enabling the execution of arbitrary Java bytecode at import time. This vulnerability can be exploited through methods such as model poisoning, MITM attacks, or dependency poisoning, leading to remote code execution. The issue arises from the direct execution of the JAR file via subprocess with unvalidated classpath input, allowing malicious classes to execute when loaded by the JVM.
Products: nltk/nltk
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | nltk | 3.9.3 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | nltk | no fix |
| Debian 13 | nltk | no fix |
| Debian 14 | nltk | 3.9.3-1 |
| Ubuntu 25.10 | nltk | no fix |
| Ubuntu 26.10 | nltk | no fix |
| Ubuntu Pro 14.04 LTS | nltk | 2.0~b9-0ubuntu4.1~esm6 |
| Ubuntu Pro 16.04 LTS | nltk | 3.1-1ubuntu0.1+esm4 |
| Ubuntu Pro 18.04 LTS | nltk | 3.2.5-1ubuntu0.1+esm4 |
| Ubuntu Pro 20.04 LTS | nltk | 3.4.5-2ubuntu0.1~esm4 |
| Ubuntu Pro 22.04 LTS | nltk | 3.7-1ubuntu0.1~esm2 |
| Ubuntu Pro 24.04 LTS | nltk | 3.8.1-1ubuntu0.1~esm2 |
| Ubuntu Pro 26.04 LTS | nltk | 3.9.2-1ubuntu0.1~esm2 |