CVE-2026-0847
Fixed in a distro release EPSS <1%CVSS 8.6
A vulnerability in NLTK versions up to and including 3.9.2 allows arbitrary file read via path traversal in multiple CorpusReader classes, including WordListCorpusReader, TaggedCorpusReader, and BracketParseCorpusReader. These classes fail to properly sanitize or validate file paths, enabling attackers to traverse directories and access sensitive files on the server. This issue is particularly critical in scenarios where user-controlled file inputs are processed, such as in machine learning APIs, chatbots, or NLP pipelines. Exploitation of this vulnerability can lead to unauthorized access to sensitive files, including system files, SSH private keys, and API tokens, and may potentially escalate to remote code execution when combined with other vulnerabilities.
Products: nltk/nltk, Red Hat OpenShift AI 2.25, Red Hat OpenShift AI 3.3, Red Hat Lightspeed Core, Red Hat OpenShift Lightspeed, Red Hat Ansible Automation Platform 2, Red Hat OpenShift AI (RHOAI)
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | nltk | no fix |
| PyPI | nltk | 3.9.3 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | nltk | no fix |
| Debian 13 | nltk | no fix |
| Debian 14 | nltk | 3.9.3-1 |
| Ubuntu 25.10 | nltk | no fix |
| Ubuntu 26.10 | nltk | no fix |
| Ubuntu Pro 14.04 LTS | nltk | 2.0~b9-0ubuntu4.1~esm6 |
| Ubuntu Pro 16.04 LTS | nltk | 3.1-1ubuntu0.1+esm4 |
| Ubuntu Pro 18.04 LTS | nltk | 3.2.5-1ubuntu0.1+esm4 |
| Ubuntu Pro 20.04 LTS | nltk | 3.4.5-2ubuntu0.1~esm4 |
| Ubuntu Pro 22.04 LTS | nltk | 3.7-1ubuntu0.1~esm2 |
| Ubuntu Pro 24.04 LTS | nltk | 3.8.1-1ubuntu0.1~esm2 |
| Ubuntu Pro 26.04 LTS | nltk | 3.9.2-1ubuntu0.1~esm2 |
| openSUSE Tumbleweed | python-nltk | 3.9.3-1.1 |