CVE-2025-8837
Fixed in a distro release EPSS <1%CVSS 5.3
A vulnerability was identified in JasPer up to 4.2.5. This affects the function jpc_dec_dump of the file src/libjasper/jpc/jpc_dec.c of the component JPEG2000 File Handler. The manipulation leads to use after free. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. The patch is named 8308060d3fbc1da10353ac8a95c8ea60eba9c25a. It is recommended to apply a patch to fix this issue.
Products: jasper_project jasper
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | jasper | 2.0.14-150000.3.37.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP7 | jasper | 2.0.14-150000.3.37.1 |
| SUSE Linux Enterprise Module for Desktop Applications 15 SP6 | jasper | 4.2.8-150600.4.5.1 |
| SUSE Linux Enterprise Module for Desktop Applications 15 SP7 | jasper | 4.2.8-150600.4.5.1 |
| SUSE Linux Enterprise Server 16.0 | jasper | 4.2.8-160000.1.1 |
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | jasper | 1.900.14-195.43.1 |
| SUSE Linux Enterprise Server for SAP applications 16.0 | jasper | 4.2.8-160000.1.1 |
| Ubuntu 16.04 LTS | jasper | no fix |
| openSUSE Leap 15.6 | jasper | 4.2.8-150600.4.5.1 |
| openSUSE Leap 16.0 | jasper | 4.2.8-160000.1.1 |
| openSUSE Tumbleweed | jasper | 4.2.8-2.1 |