CVE-2025-7458
Fixed in a distro release EPSS <1%CVSS 6.9
An integer overflow in the sqlite3KeyInfoFromExprList function in SQLite versions 3.39.2 through 3.41.1 allows an attacker with the ability to execute arbitrary SQL statements to cause a denial of service or disclose sensitive information from process memory via a crafted SELECT statement with a large number of expressions in the ORDER BY clause.
Products: SQLite
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | sqlite3 | no fix |
| Debian 13 | sqlite3 | 3.42.0-1 |
| Debian 14 | sqlite3 | 3.42.0-1 |
| Ubuntu 14.04 LTS | sqlite | no fix |
| Ubuntu 16.04 LTS | sqlite | no fix |
| Ubuntu 18.04 LTS | sqlite | no fix |
| Ubuntu 20.04 LTS | sqlite | no fix |
| Ubuntu 22.04 LTS | sqlite | no fix |