CVE-2025-71379
Fixed upstream EPSS <1%CVSS 4.3
vLLM versions >= 0.6.3 and < 0.9.0 contain multiple regular expression denial of service (ReDoS) vulnerabilities. Several regex patterns — in vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible serving chat endpoint — are susceptible to catastrophic backtracking. An attacker submitting crafted input with nested or repeated structures can trigger severe CPU consumption and performance degradation, resulting in denial of service.
Products: vllm
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | vllm | 0.9.0 |