CVE-2025-69412
Fixed in a distro release EPSS <1%CVSS 3.4
KDE messagelib before 25.11.90 ignores SSL errors for threatMatches:find in the Google Safe Browsing Lookup API (aka phishing API), which might allow spoofing of threat data. NOTE: this Lookup API is not contacted in the messagelib default configuration.
Products: kde messagelib
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | kf5-messagelib | no fix |
| Debian 13 | messagelib | no fix |
| Debian 14 | messagelib | 4:25.08.3-3 |
| Ubuntu 20.04 LTS | kf5-messagelib | no fix |
| Ubuntu 22.04 LTS | kf5-messagelib | no fix |
| Ubuntu 24.04 LTS | kf5-messagelib | no fix |
| Ubuntu 25.10 | messagelib | no fix |
| Ubuntu 26.04 LTS | messagelib | no fix |
| Ubuntu 26.10 | messagelib | no fix |
| Ubuntu Pro 18.04 LTS | kf5-messagelib | no fix |