CVE-2025-69262
Fixed upstream EPSS 1%CVSS 7.6
pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.
Products: pnpm
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | pnpm | 10.27.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | pnpm-stage0 | no fix |
| Wolfi | pnpm-stage0 | no fix |