CVE-2025-68616
Fixed in a distro release EPSS <1%CVSS 7.5
WeasyPrint helps web developers to create PDF documents. Prior to version 68.0, a server-side request forgery (SSRF) protection bypass exists in WeasyPrint's `default_url_fetcher`. The vulnerability allows attackers to access internal network resources (such as `localhost` services or cloud metadata endpoints) even when a developer has implemented a custom `url_fetcher` to block such access. This occurs because the underlying `urllib` library follows HTTP redirects automatically without re-validating the new destination against the developer's security policy. Version 68.0 contains a patch for the issue.
Products: Kozea WeasyPrint, Red Hat Ansible Automation Platform 2
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | weasyprint | 68.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | weasyprint | no fix |
| Debian 13 | weasyprint | no fix |
| Debian 14 | weasyprint | 69.0-1 |
| Ubuntu 20.04 LTS | weasyprint | no fix |
| Ubuntu 22.04 LTS | weasyprint | no fix |
| Ubuntu 24.04 LTS | weasyprint | no fix |
| Ubuntu 25.10 | weasyprint | no fix |
| Ubuntu 26.04 LTS | weasyprint | no fix |
| Ubuntu 26.10 | weasyprint | no fix |
| openSUSE Leap 16.0 | python-weasyprint | 65.1-bp160.2.1 |
| openSUSE Tumbleweed | python-weasyprint | 68.0-1.1 |